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eClass Grades Classroom Teacher Guide
WELCOME
This guide provides instructions for completing common tasks in 
eClass® Grades version 6.9.2 or higher.

For more information on any of the tasks or topics in this guide, see your 
eClass Grades User Guide or the online Help.

Getting More Information
Chancery offers many solutions to help ensure you get every advantage from 
your Chancery Student Management Solutions�.

Training � Phone 1-800-999-9931
� Go to the Support web site, http://support.chancery.com, log on, 

and then click Training
Online Help � Press F1 on your keyboard
Guides � Print the eClass Grades User Guide PDF file, on the 

Win School® CD
� Download from the Support web site, http://support.chancery.com

Technical Support Available Monday to Friday, 5 am to 5 pm Pacific Time:
� Phone 1-800-688-9939
� Fax 1-800-446-5650
� Email techsupp@chancery.com
Welcome
Getting More Information
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Year at a Glance
The tasks you and other staff at your school need to complete to get started 
using eClass Grades are as follows: 

Note

In the above illustration, the SIS, or Chancery Student Information System, is 
Win School or Mac School®.
Welcome
Year at a Glance
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Menu and Keyboard Shortcuts
To save time, use the following navigation and other shortcuts: 

To move within the Scores, Students, and Assignments windows or dialogs: 

New Class Ctrl+n

Open Class Ctrl+o

Save Class Ctrl+s

Undo Ctrl+z

Cut Ctrl+x

Copy Ctrl+c

Paste Ctrl+v

Up one row !

Down one row "

Right one column #

Left one column 

Move forward one field Tab

Move backward one field Shift+Tab

Left to first column Home

Right to last column End

Up one screen Page Up

Down one screen Page Down

Up to first row Ctrl+Up Arrow

Up to last row Ctrl+Down Arrow
Welcome
Menu and Keyboard Shortcuts
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USING eCLASS GRADES
eClass Grades displays information in four windows: 

Style preferences affect the information that displays in each window. For 
details, see �Style Files� on page 8. 

For navigation tips, see �Menu and Keyboard Shortcuts� on page 3.

Students Window � student comments
� citizenship
� work habit
� pass/fail

Scores Window � student�s scores for each assignment

Assignments Window � assignments
� bonus or extra credit assignments
� copy assignments from one class to another

Seating Charts Window � layout of your class, including arrangement of 
desks and assignment of pictures
Using eClass Grades 5
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BEFORE THE START OF THE TERM
To prepare for the start of the term, complete the following procedures in the 
order in which your school prefers and that best matches your grading 
strategy:

� establish a grading strategy

� access roster, generic class, and style files your system administrator set up 
for you

� learn to use eClass Grades

Establishing a Grading Strategy
Spending some time considering your strategy up front will make working 
with eClass Grades much easier.

Before you start working with eClass Grades, consider:

� what standard assignments you give (such as tests, homework, labs, etc.)

� what grade summaries you require

� whether you divide assignments chronologically or by period

� what types of scoring you use

� are there any standard reports your school creates for grades

Accessing Files Your Administrator Set Up
One of the first things you will typically do is access the roster, generic class, 
and style files your school system administrator set up for you on the network 
or a diskette. You will later use these files during the term to create your 
individual class files.

Roster Files

Ask your school system administrator the location of your *.rst roster files.

Generic Class Files

A generic class file is a template you can use to create class files for the classes 
you teach in the upcoming term. Using one or more generic class files saves 
you time and reduces errors.
Before the Start of the Term
Establishing a Grading Strategy
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A generic class file might contain:

� special scores

� school-wide comments

� categories and weights (not necessarily defined)

� grading periods

� overall summaries

� grading scales

� other requirements specific to each type of class taught at your school

The number of generic class files your system administrator creates depends 
on their lengths (for example, full-year courses, or first semester courses and 
second semester courses) and structure of the schedule (for example, one 
generic class file per grading period).

Style Files

Style files save customized report and onscreen preferences, such as:

� fonts and placement of data on reports

� grades on reports and onscreen

� column width (accommodate long fields)

� which student and assignment information displays on reports

Your system administrator will likely create one or more style files that follow 
your school�s established guidelines for reports and place them on the 
network or diskette for you to use.

You can:

� use style files created by your school system administrator or other 
teachers

� use the sample styles in the eClass Grades Samples folder

For directions on how to create reports with these styles, see Sample 
Reports in the eClass Grades online Help.

� create your own styles

Note

eClass Grades style files are not cross-platform. You cannot use a Windows® 
computer to open style files created on a Macintosh® computer, or vice versa.
Before the Start of the Term
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TO OPEN A STYLE FILE:

1 From the File menu, choose Open Style, and then locate and select the 
desired style file. 

Your system administrator might have created one or several style files for 
you to use. Or, you can work with the sample style files that came with 
eClass Grades. For example, select the Group Summary Style.sty file.

2 Click OK.

To verify the active style, check the status bar in the bottom-right corner 
of the main eClass Grades window. 

TO CONTROL WHICH GRADES COLUMNS DISPLAY IN THE SCORES WINDOW:

1 From the Style menu, choose Screen Prefs.

2 To select what to display on the computer screen, do one of the following:

3 Click OK.

When you change an option from the Style menu, make sure you save 
your style file changes, or your preferences are lost.

TO SAVE A STYLE FILE:

1 From the File menu, choose Save Style As.

2 Type a file name.

3 Click OK.

To Select

remove the Grade column from the 
Scores window

None (this can improve the speed of eClass 
Grades, as grades for large classes are no 
longer recalculated)

display an overall grade for 
combined grading periods

Overall Summary, and then select the overall 
summary from the popup list

display grades for a selected grading 
period

Grading Period, and then select the grading 
period from the popup list

display the grade for a particular 
assignment category in a grading 
period

Category, and then select the category and 
grading period from the popup lists
Before the Start of the Term
Accessing Files Your Administrator Set Up
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Learning to Use eClass Grades
Spend some time learning how to best use eClass 
Grades. For information on available training, see 
�Getting More Information� on page 1.
Before the Start of the Term
Learning to Use eClass Grades
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WORKING WITH eCLASS GRADES DURING 
THE TERM

The work you do with eClass Grades during the term is divided into:

At the Start of the Term

� create class files

� define assignment categories, if desired

� set up assignments

� set class preferences

In the Course of the Term

� add class assignments

� enter scores, comments, and student notes

� enter alternate grades, if desired

� create seating charts, if desired

� print reports

� if you use K12Planet®, export grades to K12Planet as often as needed

At the End of the Term

� export term marks

� print end-of-term reports

At the Start of the Term
At the start of the term, do the following:

� create class files

� define assignment categories, if desired

� set up assignments

� set class preferences

Your school system administrator will create roster files, and possibility one or 
more generic class and style files, for you to use. Using these files will save you 
time and reduce errors, however, you can also create class files from scratch.
Working with eClass Grades During the Term
At the Start of the Term
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Creating Class Files
You will need to copy these files from a network or diskette to your own 
folders. If the class files are on a network, you must first map the drive.

There are four methods for creating class files, depending on the tools you 
use. The first method is the easiest one. Here�s a summary:

For Method 1 procedures, see the following section. For procedures for 
Method 2 through 4, see your eClass Grades User Guide or the online Help.

Converting Rosters

The easiest way to get started is to 
convert a batch of rosters all at once.

Use the appropriate generic class file to 
import groups of classes of the same 
type. For example, convert all first 
semester classes at once, then all second 
semester classes, and so on.

Note

The first time you run �Convert Chancery SMS Class Files�, class files will be 
created. If you run it a second time for a class file which has previously been 
converted, a warning prompts you to confirm that you want to overwrite the file 
with a new one. The existing assignments and scores will be lost.

Do not run �Convert Chancery SMS Class Files� for a class file which already 
exists. If you wish to update the roster for an existing class file, open the class in 
eClass Grades, and choose Import Roster from the File menu.

Method 1 convert a batch of rosters all at 
once, using a generic class file as a 
template

� Select rosters to convert.
� Select the generic class file from 

which to copy grading scales, 
grading periods, and overall 
summaries, and mapped bins.

� Categories are not copied.
Method 2 convert a batch of rosters all at 

once, without using a template
� Select rosters to convert.
� Select the setup.gbk file.
� Map bins.

Method 3 import class roster files one at a 
time, for each class, using a generic 
class file as a template

� From the Class menu, choose 
Copy From.

� Set up categories and assignments 
for each class.

Method 4 import class roster files one at a 
time, for each class, without using a 
template:

� Map bins.
� Set up categories and assignments 

for each class.
Working with eClass Grades During the Term
At the Start of the Term
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TO SET THE CLASS CONVERSION PREFERENCE:

1 From the Edit menu, choose Preferences.

2 From the popup menu, choose �Chancery SMS Class Conversion�.

3 To use a generic class file to convert class files, select the �Use Generic 
Class Template� checkbox. Your system administrator must have already 
set up a generic class file and mapped bins.

To include comments when you convert the class files, leave the Include 
Comment List checkbox selected.

OR

To not use a generic class file, deselect the �Use Generic Class Template� 
checkbox. You will be prompted to map bins.

4 Click OK.

TO IMPORT YOUR STUDENT LIST AND CLASS INFORMATION:

1 To get your student list and class information, from the File menu, choose 
�Convert Chancery SMS Class Files�.

2 Locate and select the class rosters you want to convert.

You must select rosters of the same type of class. For example, all first 
semester classes or all full year classes. 

If the class rosters are on a network drive:

� To map a drive, click Network, select the drive, and click Finish.

� To connect to the mapped drive, select the drive from the dropdown 
menu.

3 Click OK.

4 If you are using a generic class file, locate and select it, and then click OK.

The setup.gbk file should be in the same folder. If the setup.gbk is not in 
the same folder and you are not using a generic class file, you are 
prompted to locate and select it.
Working with eClass Grades During the Term
At the Start of the Term
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If your system administrator did not already map the bins, you are 
prompted to do so. In the Map Bins dialog, right-click to choose the type 
of each class from the Type popup menu, and then click OK.

5 In the conversion confirmation dialog, click OK.

One class file is created for each roster you selected. The class file naming 
convention is: class name (grade level) (section number). For example, 
English 12(1).CLS.

The class files are located in the same folder as the roster files.

You can also get student lists and class information by importing a class 
roster, one at a time.

TO IMPORT A CLASS ROSTER:

1 From the File menu, choose New Class.

2 To copy data from a generic class file, from the Class menu, choose Copy 
From.

3 Select at least one checkbox.

4 Click Select File, locate and select the generic class file you want to copy 
records from, and then click OK.

5 To get your student list and class information, from the File menu, choose 
Import Roster, select the class roster, and then click OK.

6 To save the class file, from the File menu, choose Save Class As, type a 
file name, and then click Save.
Working with eClass Grades During the Term
At the Start of the Term
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Confirming Class Information

1 From the Class menu, choose Class Information.

The Class Information dialog displays information such as the course 
number, course name, and teacher name.

2 Enter information and verify any existing information is correct.

3 Click OK.

Defining Categories
After you create class files, define any 
necessary assignment categories for each 
grading period. Categories group types of 
assignments, such as projects, tests, 
homework, and labs within a grading 
period. Make sure the categories are 
appropriate for your classes.

You can:

� use the generic class file categories your system administrator set up

� create additional categories

� use only the default single assignment category for each grading period, 
called Total Points

In each grading period, up to 10 categories can be created for different types 
of assignments.
Working with eClass Grades During the Term
At the Start of the Term
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The category weight measures the relative importance of a category within 
the grading period. For example, if you set up 10 homework assignments 
worth 10 points each and 4 tests worth 25 points each; and if a student scores 
90/100 on homework and 50/100 on tests, the grade changes depending on 
the grading strategy: 

Some teachers use only one category, while others add as many categories as 
make sense for them.

TO USE THE GENERIC CLASS FILE CATEGORIES YOUR SYSTEM ADMINISTRATOR SET 
UP FOR YOU:

1 From the Class menu, choose Copy From.

2 Select the Categories checkbox.

3 Click Select File, locate the generic class file in your individual teacher 
folder, and then click OK.

TO DEFINE ADDITIONAL CATEGORIES:

If you are using only the generic class file categories, skip the following steps.

1 From the Class menu, choose Categories.

2 From the Categories For menu, choose the grading period.

3 Type a description and weight for each category.

The weight is not a percentage � it merely changes the importance of a 
category in relation to other categories.

To place a grade for a category on your reports, select �Include Grade 
Summary In Reports�. For example, you might want to include grades for 
tests, but exclude grades for homework. 

If you only have one category, deselect �Include Grade Summary In 
Reports�, as all grades will automatically be included on your reports.

To view additional categories, click the scrollbar down-arrow.
Working with eClass Grades During the Term
At the Start of the Term
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4 Repeat steps 2 to 3 for each grading period. If the categories in a grading 
period are the same as in the previous grading period, repeat step 2 and 
click �Copy From Previous Grading Period�. 

5 Click OK.

Once you define categories, it is important that you do not modify or 
delete categories that have been selected in the Assignments window, as 
this may inadvertently change assignments that are completed, and the 
grades may not calculate or export properly.

Setting Up Class Assignments
For each class, enter the assignments students will complete. Assignments are 
any task, such as a quiz, test, or homework, which are graded and count 
towards students� overall marks for the class.

In order for K12Planet replication or any calculated grade to be successful, 
every assignment must be assigned to a category.

TO SET UP CLASS ASSIGNMENTS:

1 Open a class file.

2 In the Assignments window, click in the first free Description field and 
type the name of the assignment. 

To add a row, from the Edit menu, choose Insert Row.

If you display grades in K12Planet, make sure you enter an assignment 
description that is meaningful to students and parents.

3 In the Points column, click and then type the number of points possible 
for the assignment.
Working with eClass Grades During the Term
At the Start of the Term
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4 In the Weight column, if you want, change the value.

Weights change the importance of an assignment in relation to other 
assignments within a category. Typically, the weight is 1. However, if an 
assignment, such as a homework, is more important than another 
assignment but worth the same points, increase the weight. For example:

5 If you have set up categories, select a category by clicking in the Category 
field to select the category from the popup menu.

New assignments are automatically assigned to the default category. You 
must choose a category, even if it is only the default category.

6 Use the Misc. column to enter additional information, such as page 
numbers, date assigned, or due date.

7 To move to the beginning of the next assignment row, press Enter.

In the Assignments window, different background colors indicate 
different grading periods.

Copying Class Assignments

After assignments are set up, you can 
copy them to other classes. For example, 
if you teach three English Grade 8 classes 
at different times during the week, those 
classes may contain the same 
assignments. 
Working with eClass Grades During the Term
At the Start of the Term
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TO COPY CLASS ASSIGNMENTS:

1 Open a class file.

2 To view the assignment list, click the Assign. button.

3 From the Class menu, choose Copy From.

4 In the Copy From dialog, select only Assignment List. If you are adding to 
the list, not replacing it, select �Append Instead of Replace�.

5 Click Select File, locate and select the class file you want to copy 
assignments from, and then click OK.

Setting Class Preferences
You can set default folder locations for 
opening and saving class and style files, 
and for storing backup files. In addition, 
make sure you have current backups of 
your class files. 

Your backups must be stored in a 
different location from where you 
normally save class files.

Backing Up Class Files

Make sure you save class files in at least two locations: the network location 
your school administrator specifies and your local hard drive. Diskettes are 
not reliable for storing data.

To avoid loss of data in case of computer failure, each time you update your 
class file, print the marks.

TO SAVE THE NEW CLASS FILE:

1 From the File menu, choose Save Class As.

2 Type a file name, then click OK.

TO SET DEFAULT FOLDER PREFERENCES:

1 From the Edit menu, choose Preferences.

2 From the dropdown menu, choose Default Folders.
Working with eClass Grades During the Term
At the Start of the Term
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3 From the list, select the action you are choosing a default folder for, click 
Select Folder. Locate the folder, and then click Select. 

4 Click OK.

Setting Automatic Roster Updates

You can automatically import rosters each time you open a class file.

TO SET IMPORT PREFERENCES:

1 From the Edit menu, choose Preferences.

2 From the dropdown menu, select Automatic Import.

3 Select the import options.

4 Click OK.

Protecting Class Files

For added security, use a password to protect your files.

TO SET A PASSWORD:

1 From the Class menu, choose Set Password.

2 Type a password.

3 To permit your system administrator to access your gradebook files, select 
the Allow Administrator Access checkbox. 
Working with eClass Grades During the Term
At the Start of the Term
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The Allow Administrator Access checkbox is dimmed, if your system 
administrator choose to not use this option.

4 Click OK 

5 In the confirmation dialog, retype the same password, and then click OK.

In the Course of the Term
During the term, you will:

� add class assignments

� enter scores, comments, and student notes

� enter alternate grades, if desired

� create seating charts

� print reports

� if you use K12Planet, export grades to K12Planet as often as needed

Adding Class Assignments
During the term, set up additional assignments for your classes.

TO SET UP ADDITIONAL ASSIGNMENTS:

1 Open a class file.

2 In the Assignments window, click in the first free 
Description field, and type the assignment name.

3 In the Points column, click and then type the 
number of points possible for the assignment.

4 In the Weight column, if you want, change the 
value.

5 In the Category field, click and select a category from the popup menu.

6 In the Misc. column, enter additional information.

For more information, see �Setting Up Class Assignments� on page 17.
Working with eClass Grades During the Term
In the Course of the Term
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Entering Scores
For each class assignment, you can enter a score for 
each student. Some examples are:

� whole number: 88

� decimals to nearest tenth: 8.5

� letter grade description: A+

� special score: ex 

TO ENTER A SCORE:

1 In the Scores window, click the appropriate assignment field for the 
student you want to assign a score to.

2 Type the score, and then press Enter to move to the next student.

OR

To assign the same score to a range of students, select a field in the 
appropriate assignment column. From the Edit menu, choose Fill 
Column. Type the score you want to assign and adjust the student range, if 
necessary. Click OK.

To move around the Scores window as quickly as possible, use the Jump 
To command in the Utilities menu (or press Alt + j).

If you enter an unreasonably large score, you might see a caution message 
(depending on your preferences). To change the maximum score which 
triggers the message, change the Safety Factor in Preferences. For 
example, a safety factor of 1.5 displays a caution message when you try to 
enter a score greater than 30 on a 20 point test (30 = 1.5 x 20). Bonus 
points also activate a caution message.

In the Scores window, different background colors indicate different 
grading periods.
Working with eClass Grades During the Term
In the Course of the Term



eClass Grades Classroom Teacher Guide
Entering Special Scores

In the Scores window, click the assignment field for the student you want to 
assign a special score to, then select the special score from the popup menu.

By default, an empty score is considered an Incomplete special score.

Recording Alternate Grades
You can use an alternate grade when you are not satisfied with the calculated 
grade. To do so, set up eClass Grades so you can record alternate grades for 
Categories, Grading Periods, or Overall Summaries.

The generic class file may be set up to enter alternate grades, or you can 
modify class files to allow for entry of alternate grades.

Alternate grades replace calculated grades in reports and exports to 
Win School or Mac School.

TO ALLOW RECORDING OF ALTERNATE GRADES:

1 From the Class menu, choose Categories, Grading Periods, or 
Overall Summaries. For this exercise, select Overall Summaries.

2 Select the Allow Alternate Grade checkbox, then click OK. 

3 From the Style menu, choose Screen Prefs.

4 Select the Overall Summary, Grading Period, or Category you want to 
enter alternate grades for, then click OK.
Working with eClass Grades During the Term
In the Course of the Term
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Alternate Percentage and Alternate Description columns are now visible 
in the Scores window. 

TO ENTER AN ALTERNATE GRADE:

1 In the Scores window, select a student, and then type a percentage in the 
Alternate Percent field and type a letter grade in the Alternate 
Description field.

2 If you want to report empty grades for students who have scores, select 
the Alternate Percent and Alternate Description fields for the selected 
student, and choose <blank> from the popup menu for each.

Tips for Ensuring Correct Grades
To ensure correct grades, check:

� Assignments out of zero are not the only assignments in a category
� Categories and weights out of zero are not the only ones
� Extra Credit checkbox is deselected, unless you know how to work with 

these
� Score entry
� Style preferences
� Mark according to your plan

Entering Comments
You can assign standard comments to students that will print on reports that 
you generate for students and parents.

Comments can be plain text, or they can contain comment variables that print 
individualized student data from the student�s record. You can build narrative, 
letter-style reports by giving students a series of comments that can be 
combined to make paragraphs. The contents of each comment can be up to 
250 characters.

Note

While some comments are created in eClass Grades, others are created in 
Win School or Mac School. When the system administrator changes comment 
numbers in Win School or Mac School, you need to check that the comments you 
have already entered in eClass Grades are not affected by the renumbering.
Working with eClass Grades During the Term
In the Course of the Term
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For example, if the system administrator deletes comment #5, comment #6 will 
take the position of comment #5. This means that comment #5 entries are 
replaced with the text that was formerly called comment #6.

Your system administrator should inform you when your work might be affected. 
However, it is a good idea to periodically confirm that your comment numbers are 
correct.

TO PREVIEW OR PRINT COMMENTS FOR A CLASS FILE:

1 From the Report menu, choose Comment List. 

2 Select Full Comments or Brief Comments, then click Print.

OR

Click Preview. The Comment List displays in the Preview window. If you 
want, print the comment list or close the window. 

TO CREATE YOUR OWN ADDITIONAL COMMENTS:

1 From the Class menu, choose Comments.

2 To change an existing comment, select the comment, and then click Edit. 
Comments that cannot be edited appear in italics. The Edit Comments 
dialog information will vary, depending on which class file you have open.

OR

To add a new comment to the end of the comments list, click Append.

OR

To add a new comment before the comment you currently have selected, 
click Insert.
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3 Type or change the comment, and then click OK. Each comment is 
assigned a number based on its position in the list.

4 To remove a selected comment from the list, click Delete. You cannot 
delete comments imported from Win School or Mac School.

5 Click Done.

Those comments you create appear in eClass Grades, but will not appear 
on report cards. Only the first 250 characters of school-wide comments 
created in Win School or Mac School are exported to student report 
cards. For alternate ways to add remarks to printed student reports, see 
�Student Notes� and �Post Scripts� in the eClass Grades online Help.

To copy all of the comments from one class to another class, use the Copy 
From command in the Class menu.

Assigning Comments to a Student

1 In the Students window, select a student, and then click in the Comments 
field. 

2 Type comment numbers, separated by commas.

OR

In the Comment field, click �...�, select a comment and click Add 
Comment for each comment you want, and then click Done. 

Only comments that appear in bold and italics are exported to 
Win School or Mac School and will display on student report cards.
Working with eClass Grades During the Term
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Assigning the Same Comment to a Group of Students

1 In the Students window, click in the Comments column, and then from 
the Edit menu, choose Fill Column.

2 In the �Fill Student Comments Column with� field, type a number from 
the comments list. Adjust the student range, if necessary. 

3 Click OK.

Entering Student Notes
In addition to comments, you can include messages for individual students, 
called student notes. Student notes can print on reports, but not on student 
report cards printed by the school.

If you use K12Planet, you can choose to export student notes to K12Planet.

TO ENTER A NOTE FOR A STUDENT:

1 From the Class menu, choose Student Notes. 

2 From the Student dropdown menu, choose a name.

If you have already entered comments for the 
selected students, indicate where you want the new 
comment to be added.
Working with eClass Grades During the Term
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3 Type a message.

To delete all individual student notes for a class file, such as at the end of 
the year, click �Clear Notes For All Students�.

4 Click OK.

Saving Changes to Class Files
As you update class files, regularly save your 
changes. 

TO SAVE CHANGES TO A CLASS FILE:

1 From the File menu, choose Save Class.

2 Click OK.

Working with Seating Charts
The Seating Charts window displays students assigned to a desk. It is a great 
tool for substitute teachers.

You can use it to set the desk order and re-seat students, display student 
pictures, randomly select students from a class, and create seating charts.

TO DISPLAY STUDENT PICTURES:

1 Display the Seating Charts window. If prompted to create desks, click Yes.

2 From the Class menu, choose Seating Preferences.

3 Select the Student Picture checkbox.

4 Click OK. If you are prompted to adjust desks, click OK.

TO ASSOCIATE PICTURE FILES WITH STUDENT NAMES:

1 Right-click a student desk, and choose Pictures.

OR

Select a student desk, and then choose Student Pictures from the Class 
menu.

2 From the Student dropdown menu, choose a student name.
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3 Click Add, select the picture file, then click OK.

4 Click OK.

Reporting Student Grades
During the term, there are a number of reports you 
might need to print. 

There are a variety of report options in eClass Grades, including:

� Individual reports, such as Letter-Style Reports Using Comments, 
advising parents of their child�s progress.

� Group reports, such as Bulletin Board Group Reports, which list all 
students in a class, along with scores and overall grades for selected 
assignments. For example, confidentially post grades or print a grade 
book.

� Multi-class reports, such as Multi-Class Elementary Report, which capture 
a student�s performance in several or all classes during the school year.

Customizing Report Headings and Styles

To customize a report, change the report heading and use the appropriate 
style file. A report differs depending on the style file opened on the computer 
printing the report.

You can customize the look of and placement of data on reports, as well as 
specify what information to include or exclude. For more information, see 
�Setting Class Preferences� on page 19.
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TO SET UP REPORT HEADINGS:

1 From the Class menu, choose Report Headings.

2 Type the class name you want to appear on the report.

3 If your school or department has a site license, you can also print your 
name on reports.

This allows different classes to have different teacher names, for example, 
Sr. Smith for a Spanish class or Mr. Smith for an English class. This is 
helpful for team teachers producing Multi-Class reports.

4 Click OK.

Reducing the Size of Reports

There are various methods you can use to reduce the size of reports. The 
following are some suggestions:

� Decrease font size (Style menu)

� Use Landscape orientation (File menu, Print Setup)

� Remove extraneous information (Style menu, Grades)

� Change margin settings (Style menu, General Report Prefs)

� Reserve lines (Style menu, Individual Report Prefs)

Emailing Reports

To electronically mail student reports, you must first set up individual student 
email addresses, and then send the report in an email.

TO SET UP STUDENT EMAIL ADDRESS:

1 From the Class menu, select Student Email Addresses.

2 From the Student dropdown menu, choose a student�s name.
Working with eClass Grades During the Term
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3 Type an email address for that student. For multiple email addresses, make 
sure each address is separated by a comma.

4 If desired, select another student and repeat the above steps. When 
prompted, click Save.

5 Click OK.

TO EMAIL INDIVIDUAL OR MULTI-CLASS REPORTS:

1 From the Report menu, choose the Individual or Multi-Class Report.

2 Specify your options for the selected report.

3 Click Email.

Your email software creates an email message for each selected student.

4 To preview each message before you send it, click View Message, and 
then click Send for each message.

OR 

To send all messages without previewing, click Send All.

Printing Reports

1 From the Report menu, choose a report. For example, Individual Report.

2 Specify your options for the selected report.

3 To view the report on the computer screen, click Preview.

4 Click Print.
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Exporting eClass Grades Data to K12Planet
If your school uses K12Planet, regularly export grades 
for each of your classes to the same folder that contains 
your setup.gbk and *.rst roster files, as often as is 
necessary.

TO EXPORT eCLASS GRADES TO K12PLANET:

1 From the File menu, choose Export.

2 Select the �K12Planet Grades Export� filter, and then click OK.

Note

You can also create filters to use eClass Grades data with other programs, 
such as spreadsheets or word processors. To set up an automatic export filter, 
see your eClass Grades User Guide.

3 Select the same individual folder where your setup.gbk and *.rst roster 
files are stored.

Ensure that the export file is being saved within your correct individual 
folder, and NOT a subfolder or the My Documents folder.

When you save the export file, the default name shown is the course 
number and the section number. For example, 101.004 (course 101 and 
section 004). We recommend you use the default file name.

4 Click OK.

TO SET UP K12PLANET TO DISPLAY eCLASS GRADES DATA:

1 In K12Planet, click My Students, click My Classes, and then click Grades.

2 From the popup menu, select a term.

3 In the Source column, click eClass Grades, or eClass and K12 Grades.

4 Select one of the eClass Grades, or eClass and K12 Grades checkboxes.

5 Click Save.
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At the End of the Term
At the end of each grading period or term, or when it is time to send out 
report cards, you should (in the following order):

� Step 1: export term marks 

� Step 2: print end-of-term reports

� Step 3: prepare for next term

Step 1: Exporting Term Marks to Win School or Mac School
Review and print your students� term marks and 
related information, such as citizenship, work habit 
grades, and pass/fail status. Then, export a term 
marks file (which contains that information).

Note

Setting up the Automatic Export preference does not 
export term marks.

TO EXPORT TERM MARKS:

1 From the File menu, choose Export Term Marks. 

2 From the �Export percent and letter grade for� list, select the grading 
periods and overall summaries you want to export. 

3 Deselect �Include inactive students� to send only active students� grades 
for Win School or Mac School.

If you�re not sure which grading periods and overall summaries you 
should select, ask your system administrator.
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4 From the �Comments etc. belong with� menu, choose the grading period 
or overall summary to which the comments, citizenship, work habits, 
grades, and pass/fail status belong.

5 If necessary, change the export destination.

Export to your own individual folder on the network or diskette. The 
same folder also contains your setup.gbk and *.rst roster files. Ensure that 
the export file is being saved within the correct individual folder, and 
NOT a subfolder or the My Documents folder.

6 Click OK.

Step 2: Printing End of Term Reports
At the end of each grading period or term, or when it 
is time to send out report cards, print reports. 

TO PRINT A REPORT:

1 From the Report menu, choose a report.

2 Specify your options for the selected report. 

3 To view the report on the computer screen, click Preview.

4 Click Print.

Step 3: Considering the Success of the Previous Term
Reflect on what you did before the start of the 
previous term, and consider how it relates to the next 
term.
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PREPARING FOR THE NEXT TERM
At the end of each grading period or term:

� update class files

� set up a new grading period

Updating Class Files
When classes change, you will want to import new class rosters, one at a time.

Use the updated set of class roster files from your system administrator, and 
repeat the following procedures for each new class you teach.

TO CREATE A CLASS FILE:

1 From the File menu, choose New Class.

2 To copy data from a generic class file, from the Class menu, choose Copy 
From. 

3 Select at least one checkbox.

4 Click Select File, locate and select the generic class file you want to copy 
records from, and then click OK.

5 To get your student list and class information, from the File menu, choose 
Import Roster, select the class roster, and then click OK.

6 To save the class file, from the File menu, choose Save Class As, type a file 
name, and then click Save.
Preparing for the Next Term
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Removing Student Comments
You do need to remove old comments. Comments you enter for the new 
grading period overwrite those previously assigned to students.

Comments are included in the marks file your system administrator imports 
into Win School or Mac School each term.

Setting Up a New Grading Period
After updating your class files, configure eClass Grades in preparation for the 
next grading period of the school year.

1 For each class, in the Assignments window, verify the number of 
assignments in the first grading period.

2 From the Class menu, choose Grading Periods.

3 For the new grading period, in the Starting Assignment field, type the 
number of assignments plus one, and then click OK.

For example, if you gave 20 assignments during the first grading period, 
type 21 as the starting assignment number for the second grading period. 

4 In the Include in Reports section, select the checkbox to include each 
whole grading period�s grade on reports. If you use categories for subjects, 
deselect Grade Summary.

5 Click OK.

6 In the Assignments window, enter assignments for the new grading 
period. Append new assignments to the bottom of the existing list.

Yellow highlighting separates the different grading periods.

7 Change your preferences to display the new grading period information. 
For procedures, see �Style Files� on page 8.
Preparing for the Next Term
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AT YEAR END
At the end of the school year:

� Print end-of-year reports

� Export final marks

Needs differ from school to school. Use the procedures appropriate for 
your school.

Creating Reports
You can generate a variety of reports and graphs, 
and customize them using the Class and Style 
menus. 

For more information, see �Reporting Student Grades� on page 29.

Exporting Final Grades
At the end of the year, export the final grades for 
students. 

For more information, see �Step 1: Exporting 
Term Marks to Win School or Mac School� on 
page 33, and if your school uses K12Planet, also 
see �Exporting eClass Grades Data to 

                                           K12Planet� on page 32.
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