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eClass Grades System Administration Guide
WELCOME
This guide provides instructions for completing common tasks in 
eClass® Grades version 6.9.2 or higher.

For more information on any of the tasks or topics in this guide, see your 
eClass Grades User Guide or the online Help.

Getting More Information
Chancery offers many solutions to help ensure you get every advantage from 
your Chancery Student Management Solutions�.

Training � Phone 1-800-999-9931
� Go to the Support web site, http://support.chancery.com, log on, 

and then click Training
Online Help � Press F1 on your keyboard
Guides � Print the eClass Grades User Guide PDF file, on the 

Win School® CD
� Download from the Support web site, http://support.chancery.com

Technical Support Available Monday to Friday, 5 am to 5 pm Pacific Time:
� Phone 1-800-688-9939
� Fax 1-800-446-5650
� Email techsupp@chancery.com
Welcome
Getting More Information
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Year at a Glance
The tasks you and other staff at your school need to complete to get started 
using eClass Grades are as follows: 

Note

In the above illustration, the SIS, or Chancery Student Information System, is 
Win School or Mac School®.
Welcome
Year at a Glance
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Menu and Keyboard Shortcuts
To save time, use the following navigation and other shortcuts: 

To move within the Scores, Students, and Assignments windows or dialogs: 

New Class Ctrl+n

Open Class Ctrl+o

Save Class Ctrl+s

Undo Ctrl+z

Cut Ctrl+x

Copy Ctrl+c

Paste Ctrl+v

Up one row !

Down one row "

Right one column #

Left one column 

Move forward one field Tab

Move backward one field Shift+Tab

Left to first column Home

Right to last column End

Up one screen Page Up

Down one screen Page Down

Up to first row Ctrl+Up Arrow

Up to last row Ctrl+Down Arrow
Welcome
Menu and Keyboard Shortcuts
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USING eCLASS GRADES
eClass Grades displays information in four windows: 

Style preferences affect the information that displays in each window. For 
details, see �Changing Style File Properties� on page 16. 

For navigation tips, see �Menu and Keyboard Shortcuts� on page 3.

Students Window � student comments
� citizenship
� work habit
� pass/fail

Scores Window � student�s scores for each assignment

Assignments Window � assignments
� bonus or extra credit assignments
� copy assignments from one class to another

Seating Charts Window � layout of your class, including arrangement of 
desks and assignment of pictures
Using eClass Grades 5
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BEFORE THE START OF THE TERM
To prepare for the start of the term, complete the following procedures in the 
order in which your school prefers and that best matches your grading 
strategy:

� establish a grading strategy

� allow access to eClass Grades files

� create roster files

� create a setup file

� create a generic class file

� change style file properties (optional)

� help teachers get started

Establishing a Grading Strategy
Spending some time considering your strategy up front will make working 
with eClass Grades much easier.

Before you start working with eClass Grades, consider:

� what standard assignments do teachers give (such as tests, homework, 
labs, etc.)

� what grade summaries do teachers require

� do teachers divide assignments chronologically or by period

� what types of scoring do teachers use

� are there any standard reports your school creates for grades

Allowing Access to eClass Grades Files
You can access teacher directories and class files on the network server. For 
example, principals, vice-principals, and counselors might need to access 
teacher gradebooks when discussing a student�s overall performance with a 
student and their parents.

When eClass Grades is set up on the network for the first time, you need to:

� Create an eClass Grades parent (root) directory containing the teachers� 
directories and class files.
Before the Start of the Term
Establishing a Grading Strategy

7



eClass Grades System Administration Guide

8

� Grant read access rights to the parent directory and its subdirectories for 
principals, vice-principals, and counselors and read/write access for 
teachers and users.

� Create an ID of up to seven characters for each teacher. This ID is also 
the name of each teacher�s data directory within the eClass Grades parent 
directory. The teacher directory is the directory from which teachers 
import their class rosters and to which they export their term marks.

� Create a master password to allow administrative users to access teacher 
gradebooks. Depending on how eClass Grades is installed, teachers might 
be able to change the �Allow Administrator Access� option for their 
classes.

Accessing Teachers� Class Files
When you create class roster files for teachers:

� A teacher directory is created within the parent eClass Grades directory 
for each teacher. Each teacher directory is named according to the ID 
assigned to the teacher in School Setup, in Win School or Mac School. If 
class files are stored on diskette, no directories are created.

� A file called TCH_ID.TXT is created in the parent directory. It lists each 
teacher ID and the corresponding teacher name.

TO VIEW A TEACHER’S GRADEBOOK FILES:

1 Print the TCH_ID.TXT file located in the parent eClass Grades data 
directory on the network server.

2 Locate the subdirectory within the eClass Grades directory that 
corresponds to the name of the teacher whose files you want to view.

3 Start eClass Grades, then open the gradebook file in the teacher�s 
directory and type the master password.

Note

If you cannot access the teacher�s class file with the master password, ask 
the teacher whether they deselected the �Allow Administrator Access� option, 
in the eClass Grades Set Password dialog.
Before the Start of the Term
Allowing Access to eClass Grades Files
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Creating Roster Files
One of the first things you will typically do is 
create roster files and distribute them to 
teachers. You can either write the files to 
diskettes or to teachers� folders on your hard 
disk or network. Teachers will then use these 
files to create their individual class files.

You can also copy generic class and style files using the Additional Items 
feature, described in �Copying Files Using Write Teacher�s Classes� on 
page 18.

You choose whether to write all or selected classes, teachers, terms, and bins.

TO CREATE ROSTER FILES:

1 In Win School or Mac School, open the Reports Cards module.

2 From the Marks menu, choose Write Teacher�s Classes.

3 Select the terms to write class rosters for.

The names of all scheduled teachers and their user ID�s for the selected 
terms appear.

4 Select the names of teachers to write classes for. To write only specific 
classes for a teacher, click and select classes.

5 From the File Format popup menu, choose eClass Grades.

6 From the Destination popup menu, choose to write the files to diskettes 
or to individual teacher folders.

7 If you are writing the files to a folder on a hard disk or networked 
computer, click Folder, locate and open the parent (root) folder, and then 
click OK.

eClass Grades creates a hierarchy of individual teacher folders within this 
parent folder. Each subfolder is named after the teacher ID assigned to 
each teacher in the School Setup module of Mac School or Win School.

Note

Do not select Write Setup File. You only select this checkbox to create a setup 
file.

8 Click Write.

Roster files are created in each teacher�s folder.

9 If you are using diskettes, follow the onscreen instructions to switch 
diskettes as needed. You need one diskette for each teacher. Label each 
diskette with the name of the teacher.
Before the Start of the Term
Creating Roster Files
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Note

To write only specific classes, select them in the Main window first. These 
classes are selected by default in the Write Teachers� Classes dialog.

10 Click Close.

Creating a Setup File
The setup file is imported into eClass Grades in order to create generic class 
files. The setup file includes information from the Win School or Mac School 
comments library, Points and Credits Tables, and bins.

You must have access to the Win School or Mac School Report Cards module 
to create a setup file.

TO CREATE A SETUP FILE:

1 In Win School or Mac School, open the Reports Cards module.

2 From the Marks menu, choose Write Teacher�s Classes.

3 Choose bins for reporting.

4 In Teachers/Classes, deselect all teachers.

5 From the File Format popup menu, choose eClass Grades.

6 From the Destination popup menu, choose where to write files.

If you are writing files to a folder on a hard disk or networked computer, 
click Folder, locate and select the parent (root) folder where you wrote 
class rosters.

7 Verify that Write Setup File is selected.

8 Click Write. If you are using diskettes, switch diskettes as needed.

9 When the Write Teachers� Classes dialog reappears, click Close.

10 If you put the setup file on a diskette, give the diskette to the person who 
creates the generic class file.

Creating a Generic Class File
A generic class file is a template teachers can use 
to create class files for the classes they teach in 
the upcoming term. Using one or more generic 
class files saves staff time and reduces errors.
Before the Start of the Term
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A generic class file might also contain:

� special scores

� school-wide comments

� categories and weights (not necessarily defined)

� grading scales

� other requirements specific to each type of class taught at your school

The number of generic class files you create depends on their lengths (for 
example, full-year courses, or first semester courses and second semester 
courses) and structure of the schedule (for example, one generic class file per 
grading period).

To create a generic class file, complete the following steps:

Step 1: Create a Class File

Step 2: Import the Setup File

Step 3: Map Bins

Step 4: Set Up Grading Periods

Step 5: Set Up Overall Summaries

Step 6: Include Optional Information

Step 1: Create a Class File

1 Start eClass Grades.

2 From the File menu, choose New Class.

Step 2: Import the Setup File

1 From the File menu, choose Import. 

2 Double-click Win School or Mac School Setup Information.

3 Locate and select the SETUP.GBK file, and then click OK.
Before the Start of the Term
Creating a Generic Class File
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Step 3: Map Bins

Use the Map Bins dialog to define where marks or scores for each specific bin 
in Win School or Mac School will be entered into the class file.

In order to export term marks later, you must map at least one bin.

TO MAP BINS:

1 For each bin, right-click in the Type column and select an option. 

Notice the difference between grading period and overall summary. A 
grading period is strictly chronological; an assignment or activity belongs 
to only one grading period. An overall summary is an average of one or 
more grading periods. Therefore, a semester overall summary might be a 
summary of the first and second quarter grading periods.

2 Click OK.

Step 4: Set Up Grading Periods

A grading period contains one or more assignments in one or more 
categories. Each assignment is contained in only one grading period. For 
example:

In the Assignments and Scores windows, different background colors indicate 
different grading periods.
Before the Start of the Term
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TO SET UP GRADING PERIODS:

1 From the Class menu, choose Grading Periods.

2 Adjust the weight to change the importance of a grading period in relation 
to the overall summary to which it belongs.

From the When Calculating Grade popup menu, choose how the grading 
period averages are affected by category weights.

Select to include the grade summary for this grading period in the Grade 
Summary Report.

3 Click OK.

Step 5: Set Up Overall Summaries

Overall Summaries average two or more grading periods, such as semester 
grades and final grades. For example, for the first semester you might have:

Quarter 1............. Grading Period
Quarter 2............. Grading Period = Overall Summary
Mid term exam.... Grading Period

TO SET UP OVERALL SUMMARIES:

1 From the Class menu, choose Overall Summaries.

2 From the Include and Through menus, select the range of grading periods 
to include in the summary.

3 Indicate how to handle grading period weights for the summary. For 
example, select �Use grading period weights� so the overall summary 
period grade will take into account the weights of the grading periods.

4 Under Include In Reports, choose how grades will print in reports for the 
selected reporting period. 

To view additional overall summaries, scroll down.

5 Click OK.
Before the Start of the Term
Creating a Generic Class File
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Step 6: Include Optional Information

You can add optional information to generic class files, such as categories and 
special scores. Only add this information if it�s consistent for a large number 
of class types. Otherwise, teachers can add this information later to their 
individual class files.

Note

The �Convert Chancery SMS Class Files� feature will not transfer categories or 
special scores to teacher�s class files when you are using a generic class file.

Set Up Categories

A generic class file would not usually have any categories. However, should 
your school require generic categories, follow this procedure to create 
categories appropriate for teachers� classes.

In each grading period, up to 10 categories can be created for different types 
of assignments.

For more information, see �Defining Categories� on page 33.

TO SET UP A CATEGORY:

1 From the Class menu, choose Categories.

2 From the Categories For menu, select a grading period. The default is the 
most recently defined grading period.

3 For each category, enter the appropriate information. 

The weight is not a percentage � it merely changes the importance of a 
category in relation to other categories.

To place a grade for a category on your reports, select �Include Grade 
Summary In Reports�. For example, you might want to include grades for 
tests, but exclude grades for homework. 

If you only have one category, deselect �Include Grade Summary In 
Reports�, as all grades will automatically be included on your reports.
Before the Start of the Term
Creating a Generic Class File



eClass Grades System Administration Guide
4 Repeat the above steps for each grading period.

To view additional categories, scroll down.

If the categories in this grading period are the same as the previous 
grading period, click �Copy From Previous Grading Period�.

For additional grading periods, repeat the above steps.

5 Click OK.

Set Up Special Scores

The pre-defined special scores are Dropped, Excused, and Incomplete. An 
Excused score, for example, could be entered when a student turns in a late 
assignment due to illness, or when a student starts class several weeks after the 
beginning of a school year.

If you want, create unique Special Scores to fit your school�s grading 
procedures. For example, you can design a score, called Outstanding, 
abbreviated �+�, which eClass Grades interprets as 100% of the points 
possible on any assignment.

TO SET UP SPECIAL SCORES:

1 From the Class menu, choose Special Scores. 

2 To update an existing special score, select an item in the list, and then click 
Edit.

OR

To add a new special score, click New Score.

3 Type or change the abbreviation, such as OK, which appears in the Scores 
window and on reports.

4 Type or change the percentage equivalent, which is used for determining 
points earned on an assignment. 
Before the Start of the Term
Creating a Generic Class File
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5 Select or change the selection of an option to indicate how this score is to 
be applied to grades and statistical calculations:

� Student Grades & Class-Wide Stats to include the special score for 
both student and class-wide statistical calculations.

� Student Grade Calculations Only to include special score only when 
calculating grades for individual students.

� No Calculations to enter special score without including it in 
calculations.

6 If you want, select a color from the dropdown menu to assign it to a 
special score. For example, you can make scores for incomplete stand out 
in the Scores window by assigning the color red.

7 Click OK, and then click Done.

Saving the Generic Class File
1 From the File menu, choose Save Class As.

2 Type a file name.

3 Click OK.

4 Post one generic class file in each teacher�s folder on the network or save 
to diskette, so teachers may access them.

It is a good idea to make a duplicate generic class file, in case anyone 
overwrites your file by accident.

Changing Style File Properties
Style files save customized report and onscreen 
preferences, such as:

� fonts and placement of data on reports

� grades on reports and onscreen

� column width (accommodate long fields)

� which student and assignment information 
displays on reports

To see examples of how styles affect onscreen and report information, look at 
the sample styles included with eClass Grades. Then, choose to create as 
many styles as you want.
Before the Start of the Term
Changing Style File Properties
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When you save a style file on one computer, and then go to another computer 
to open a file, a different style opens. This is because style files are not saved 
with class files. eClass Grades automatically opens the previously-used style 
file on that computer.

Note

eClass Grades style files are not cross-platform. You cannot use a Windows® 
computer to open style files created on a Macintosh® computer, or vice versa.

TO OPEN A STYLE FILE:

1 From the File menu, choose Open Style, and then locate and select the 
desired style file. 

For example, open one of the sample styles that came with eClass Grades, 
such as the Group Summary.sty file. 

2 Click OK.

To verify the active style, check the status bar in the bottom-right corner 
of the main eClass Grades window. 

TO CONTROL HOW GRADES DISPLAY IN REPORTS OR ONSCREEN:

1 From the Style menu, choose Grades.

2 Select what to display in reports, along with display and rounding options.

Note that the rounding options teachers save in the Style file will affect 
how grades will be exported to Win School or Mac School. Therefore, 
grade rounding may not be consistent between teachers and classes.

3 Click OK.
Before the Start of the Term
Changing Style File Properties
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TO CONTROL WHICH GRADES COLUMNS DISPLAY IN THE SCORES WINDOW:

1 From the Style menu, choose Screen Prefs.

2 To select what to display on the computer screen, do one of the following:

3 Click OK.

When you change an option from the Style menu, make sure you save your 
style file changes, or your preferences are lost.

TO SAVE A STYLE FILE:

1 From the File menu, choose Save Style As.

2 Type a file name.

3 Click OK.

4 Post a copy of the style file in each teacher�s folder on the network or save 
to diskette.

Copying Files Using Write Teacher’s Classes

You can write additional files, such as generic class files and style files, into 
each teacher�s directory or diskette using Write Teacher�s Classes.

TO ADD ADDITIONAL ITEMS:

1 In Win School or Mac School, open the Reports Cards module.

2 From the Marks menu, choose Write Teacher�s Classes.

3 Select the terms and the names of teachers to write class rosters for.

4 From the File Format popup menu, choose eClass Grades.

5 From the Destination popup menu, choose to write the files to diskettes 
or to individual teacher folders.

6 If you are writing the files to a folder on a hard disk or networked 
computer, click Folder, locate and open the folder, and then click OK.

To Select

remove the Grade column from the 
Scores window

None (this can improve the speed of eClass 
Grades, as grades for large classes are no 
longer recalculated)

display an overall grade for 
combined grading periods

Overall Summary, and then select the overall 
summary from the popup list

display grades for a selected grading 
period

Grading Period, and then select the grading 
period from the popup list

display the grade for a particular 
assignment category in a grading 
period

Category, and then select the category and 
grading period from the popup lists
Before the Start of the Term
Changing Style File Properties
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7 Below Additional Items, click Add.

8 In the �Select File to Distribute to Teachers� dialog, select the generic 
class file you created in the previous procedures, and then click OK.

9 Click Add again, select the style files you created in the previous 
procedures, and then click OK.

10 Click Write, and then click Close.

Getting Teachers Started
Before the start of the term, train other staff on 
how to best use the eClass Grades files you have 
set up. 
Before the Start of the Term
Getting Teachers Started
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WORKING WITH eCLASS GRADES DURING 
THE TERM

The work you do with eClass Grades during the term is divided into:

At the Start of the Term

� update roster files

� update generic class files

In the Course of the Term

� be available as a teachers� resource

At the End of the Term

� import term marks into Mac School or Win School

� print the Missing Bin Mark Report

At the Start of the Term
At the start of the term, do the following:

� update roster files

� update generic class files

Updating Roster Files
At the start of each term, update roster files and 
distribute them to teachers. For more information, 
see �Creating Roster Files� on page 9. 

TO CREATE ROSTER FILES:

1 In Win School or Mac School, open the Reports Cards module.

2 From the Marks menu, choose Write Teacher�s Classes.

3 Select the terms and teachers� names to write class rosters for.

4 From the File Format popup menu, choose eClass Grades.

5 From the Destination popup menu, choose to write the files to diskettes 
or to individual teacher folders.
Working with eClass Grades During the Term
At the Start of the Term
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6 To specify a folder, click Folder, locate and open the parent (root) folder, 
and then click OK.

7 Click Write, then click Close.

Updating Generic Class Files
If necessary, also update generic class files and give 
a copy to teachers.

1 In eClass Grades, from the File menu, choose Open Class.

2 Select the generic class file you want to update, and then click Open.

3 Make the necessary changes. For more information, see �Creating a 
Generic Class File� on page 10.

4 From the File menu, choose Save Class As.

5 Type a file name, and click Save.

6 Post the updated generic class file in teachers� files.

7 Create a duplicate of the updated generic class file, in case anyone 
overwrites your file by accident.

Note

Teachers complete the remaining procedures during the term. To review the 
teachers� information, see �Appendix A� on page 31.

In the Course of the Term
If your school uses K12Planet®, prompt teachers to regularly export grades 
for each of their classes, as often as necessary.

Otherwise, you don�t have any specific eClass Grades tasks to perform in the 
course of the term. However, you might want to be available as a resource to 
teachers.

For information on the procedures teachers complete at this time, see 
�Appendix B� on page 37.

Exporting eClass Grades Data
Teachers export grades for each of their classes to the same folder that 
contains their setup.gbk and *.rst roster files, as often as is necessary.
Working with eClass Grades During the Term
In the Course of the Term
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At the End of the Term
At the end of each grading period or term, or at report card time, you should 
(in the following order):

� Step 1: export term marks to Mac School or Win School

� Step 2: print the Missing Bin Mark Report

� Step 3: prepare for next term

Note

To view the tasks teachers complete at the end of the term, see �Appendix C� 
on page 45.

Exporting Term Marks to Win School or Mac School
Help teachers to identify which bin to associate comments with and which 
bins to export.

Make sure they export to their individual teacher folders, and not a subfolder 
or the My Documents folder.

Remind teachers that the rounding options they save in the Style file will 
affect how grades will be imported to Win School or Mac School. Therefore, 
grade rounding may differ between teachers and classes.

The person responsible for collecting term marks, calculating class averages 
and honor rolls, and printing report cards will then import the term marks 
files into Win School or Mac School. In addition to marks, the file will include 
related student data, such as comment numbers, citizenship, work habits, 
pass/fail status, and withdrawn students who may or may not be inactive. (An 
active student is currently enrolled in the school; an inactive student is not 
currently enrolled.)

Step 1: Importing Term Marks into Win School or Mac School
When all or most teachers have submitted their 
students� term marks, import them into 
Win School or Mac School. 

TO IMPORT TERM MARKS:

1 In Report Cards, from the Marks menu, choose Upload Bin Marks.

2 In the Teachers list, select all teachers.

3 In the Classes list, select all classes.
Working with eClass Grades During the Term
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4 Under Bins, select the bins (grading periods) to upload.

5 Under Source, select Individual Teacher Folders or Diskettes.

Make sure this is the same location where you stored class rosters (.rst) 
and setup (.gbk) files.

6 Click Upload.

7 Click Close.

Step 2: Printing the Missing Bin Marks Report in Win School or 
Mac School

At the end of the term, print the Missing Bin Mark 
Report using Win School or Mac School. 

The Missing Bin Mark Report lets you search for 
and identify classes and students with missing 
marks or incomplete mark information.

You can also print individual reports for each 
teacher who has not supplied complete 
information.

TO PRINT A MISSING BIN MARK REPORT:

1 In Report Cards, from the Reports menu, choose Missing Bin Marks.

2 Select the term for which you are preparing reports.

3 Select a Missing Field item that you want teachers to submit, usually a 
percent or letter grade.

4 Select the bins to report on. You must select at least one bin to be able to 
print the report. 

5 Select the contents of the report. You can print a report of: 

� Classes for which all students are missing information in the field you 
selected.

� Classes in which one or more students is missing information in the 
field you selected, including the students� names. 

6 Click Print.
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Recalculating Bins

When all term marks have been submitted, you might want to calculate the 
grade points and earned credits in each class.

TO RECALCULATE BINS:

1 In Report Cards, select the student records and classes that do not have 
the calculated grade points or earned credits displaying.

2 From the Marks menu, choose Recalc Bins.

3 Select the bins you want to recalculate.

4 Click OK.

Exporting Mac School or Win School Data to K12Planet
If your school does not use K12Planet, skip this section.

The first time, manually export to K12Planet. After that, schedule automatic, 
periodic exports to K12Planet. For more information, see your K12Planet 
System Administrator Guide.

TO MANUALLY EXPORT THE SCHOOL’S DATABASE TO K12PLANET:

1 In Mac School or Win School, click K12Planet Link.

2 For Mac School only, click Start Replication.

Your school data is copied to the K12Planet web site for your school 
community to view.

TO SCHEDULE THE AUTOMATIC EXPORT OF THE SCHOOL’S DATABASE TO 
K12PLANET:

1 In the Mac School Shell, from the File menu, choose Auto Launch Setup.

OR

In the Win School Shell, from the Shell menu, choose Auto Launch Setup.

2 Click Enable Auto Launch, enter a time, and click OK.

Changes to your school�s data will be regularly copied to the K12Planet 
web site, as per this schedule.

Displaying eClass Grades in K12Planet
1 On the K12Planet Publishing page, select the eClass Grades checkbox.

2 Instruct teachers to select to display eClass Grades information in 
K12Planet, for each class and for each term.
Working with eClass Grades During the Term
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Step 3: Considering the Success of the Previous Term
Reflect on what you and other staff did before the start of the previous term, 
and consider how it relates to the next term.
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PREPARING FOR THE NEXT TERM
At the end of each grading period or term:

� create up-to-date generic class files 

� create class roster files

Updating Generic Class Files
If necessary, change the existing generic class files 
to best suit your staff �s needs for the next term. 

You might also want to create one or more new 
generic class files. For more information, see 
�Creating a Generic Class File� on page 10.

Note

Do not modify or delete categories for which teachers have already entered 
assignments. Modifying or deleting categories may inadvertently change 
completed assignments and the grades may not calculate or export as expected.

Updating Class Files
To update any changes to class schedules, following the procedures in 
�Creating Roster Files� on page 9.

If teachers did not set up the automatic import rosters feature, instruct them 
to import the new roster files for each class (from the File menu, choose 
Import Roster).
Preparing for the Next Term
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AT YEAR END
At the end of the school year:

� Import students� final marks

� Archive, then delete files that are no longer in use

Needs differ from school to school. Use the procedures appropriate for 
your school.

Importing Final Grades
At the end of the year, import the final grades 
for students. For procedures, see �Step 1: 
Importing Term Marks into Win School or 
Mac School� on page 23. 

Deleting Class Files
After you import final marks and archive the 
appropriate files, delete any obsolete class files 
no longer required. 

There is no command for deleting class or style 
files in eClass Grades. You can delete class or 
style files as you would any other file in the 
Windows operating system.

TO DELETE CLASS OR STYLE FILES:

1 First, back up or copy files to an archive folder.

2 Locate and open the folder that contains the files.

3 Highlight the files, and then press the Delete button.
At Year End
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APPENDIX A
Teachers complete the procedures in this section. To better understand 
teachers� tasks and be available as a resource, review this appendix, as well as 
appendices B and C.

Teachers� Tasks at the Start of Term
At the start of each term or grading period, teachers set up their classes by:

1 Creating class files, using a generic class file, and then importing or 
converting roster files.

2 Setting up assignment categories, if they use them. For example, 
homework, labs, exams.

3 Setting up assignments.

4 Setting class preferences.

Creating Class Files
Teachers copy the roster files you create for them (by completing the 
procedure in �Creating Roster Files� on page 9) to their own folders. If the 
files are on a network, teachers must first map the drive.

Teachers may also use one or more generic class and style files, if you created 
those for them by completing the procedures in �Creating a Generic Class 
File� on page 10 and �Changing Style File Properties� on page 16. Otherwise, 
teachers create their own files from scratch.

There are four methods for creating class files, depending on the tools you 
use. The first method is the easiest one. Here�s a summary:

Method 1 convert a batch of rosters all at 
once, using a generic class file as a 
template

� Select rosters to convert.
� Select the generic class file from 

which to copy grading scales, 
grading periods, and overall 
summaries, and mapped bins.

� Categories are not copied.
Method 2 convert a batch of rosters all at 

once, without using a template
� Select rosters to convert.
� Select the setup.gbk file.
� Map bins.

Method 3 import class roster files one at a 
time, for each class, using a generic 
class file as a template

� From the Class menu, choose 
Copy From.

� Set up categories and 
assignments for each class.

Method 4 import class roster files one at a 
time, for each class, without using a 
template:

� Map bins.
� Set up categories and 

assignments for each class.
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Converting Rosters

At the beginning of the term, teachers 
convert rosters. Converting a batch of 
rosters all at once is the easiest way for 
teachers to get started.

Note

The first time you run �Convert Chancery SMS Class Files�, class files will be 
created. If you run it a second time for a class file which has previously been 
converted, that file will be over-written with a new one, and you'll lose any 
assignments and scores previously entered.

Do not run �Convert Chancery SMS Class Files� for a class file which already 
exists. If you wish to update the roster for an existing class file, open the class in 
eClass Grades, and choose Import Roster from the File menu. 

TO CREATE CLASS FILES:

1 First, set your class conversion preference:

� From the Edit menu, choose Preferences.

� From the popup menu, choose �Chancery SMS Class Conversion�.

2 Next, import the student list and class information:

� From the File menu, choose �Convert Chancery SMS Class Files�.

� Locate and select the class rosters to convert. Teachers must select the 
same type of class roster for each batch. For example, convert all first 
semester classes, then convert all second semester classes, and so on.

If the teachers� class rosters are on a network drive, teachers need to 
map the drive.

One class file will be created in the same folder as each selected roster.

3 Then, confirm the class information for each class file. From the Class 
menu, choose Class Information, and enter the necessary information or 
verify the existing information is correct.
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Defining Categories
After teachers create their class files, they 
need to define any necessary assignment 
categories for each grading period. 

Teachers can either:

� create categories (from the Class menu, choose Categories)

� use the generic class file categories (from the Class menu, choose Copy 
From)

� use only the default single assignment category for each grading period, 
called Total Points

Setting Up Class Assignments
For each class, teachers enter the assignments students will complete.

For K12Planet grades or grade calculations to be successful, every assignment 
must be assigned to a category.

TO SET UP CLASS ASSIGNMENTS:

1 Open a class file.

2 From the View menu, select Assignments Window. 

3 Enter the appropriate information. 
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Copying Class Assignments

After assignments are set up, teachers can 
copy them to other classes.

TO COPY CLASS ASSIGNMENTS:

1 Open a class file and show the 
assignment list.

2 From the Class menu, choose Copy 
From.

Setting Class Preferences
Teachers set default folder locations for 
opening and saving class and style files, 
and for storing backup files.

Backing Up Class Files

Instruct teachers to back up their files to the network locations you specify.

TO SET DEFAULT FOLDER PREFERENCES:

1 From the Edit menu, choose Preferences.

2 From the dropdown menu, choose Default Folders. 

3 From the list, select the action you are choosing a default folder for, then 
click Select Folder.

4 Locate the folder, and then click Select.
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Setting Automatic Roster Updates

Teachers can configure eClass Grades to automatically import rosters each 
time they open a class file.

TO SET IMPORT PREFERENCES:

1 From the Edit menu, choose Preferences.

2 From the dropdown menu, select Automatic Import. 

3 Select the import options, then click OK.

Protecting Class Files

For added security, teachers can use a password to protect their files.

TO SET A PASSWORD:

1 From the Class menu, choose Set Password.

2 Teachers can select the Allow Administrator Access checkbox, to allow 
you access their gradebooks.

The Allow Administrator Access checkbox is dimmed if, during 
installation, you choose to not let teachers use this option for their class 
files. 
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APPENDIX B
Teachers complete the procedures in this section. To better understand 
teachers� tasks and be available as a resource, review this appendix, as well as 
appendices A and C.

Teachers� Tasks During the Term
During the term, teachers need to:

� add class assignments

� enter scores, comments, and student notes

� enter alternate grades (if desired)

� create seating charts

� print reports

� if your school uses K12Planet, teachers also need to periodically export 
grades

Adding Class Assignments
During the term, teachers might need to set up 
additional assignments for their classes.

TO SET UP ADDITIONAL ASSIGNMENTS FOR CLASSES.

1 Open a class file.

2 In the Assignments window, click in the first free Description field and 
type the name of the assignment.

3 In the Points column, type the number of points possible for the 
assignment.

4 In the Weight column, if you want, change the value.

5 To select a category, click in the Category field and select from the popup 
menu.

6 In the Misc. column, enter additional information.
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Entering Scores
For each class assignment, teachers will enter scores 
for each student.

TO ENTER A SCORE:

� In the Scores window, click an assignment field, and then type a score or 
select a special score. 

By default, an empty score is considered an Incomplete special score.

Recording Alternate Grades
Teachers can use an alternate grade when they�re not satisfied with the 
calculated grade and want to replace it. They can record alternate grades for 
Categories, Grading Periods, or Overall Summaries.

TO ALLOW RECORDING OF ALTERNATE GRADES:

1 From the Class menu, choose Categories, Grading Periods, or 
Overall Summaries.

2 Select the Allow Alternate Grade checkbox.

3 From the Style menu, choose Screen Prefs.

4 Select the Overall Summary, Grading Period, or Category to enter 
alternate grades for.

TO ENTER AN ALTERNATE GRADE:

� In the Scores window, select a student, and then enter the appropriate 
information.
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Entering Comments
Teachers can assign standard comments that will print on reports to students 
and parents.

Note

If you change comment numbers in Win School or Mac School, inform teachers 
that the comments they have already entered in eClass Grades may be affected. 
For example, if you delete comment #5, comment #6 will take the position of 
comment #5. This means that comment #5 entries are replaced with the text that 
was formerly called comment #6.

Remind teachers that it is a good idea to periodically confirm that their comment 
numbers are correct.

TO PREVIEW OR PRINT THE LIST OF COMMENTS FOR A CLASS:

� From the Report menu, choose Comment List. 

TO CREATE YOUR OWN ADDITIONAL COMMENTS:

� From the Class menu, choose Comments.

Assigning Comments to a Student

� In the Students window, select a student, and then type the comment in 
the Comments column. 
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Assigning the Same Comment to a Group of Students

� In the Students window, click in the Comments column, and then from 
the Edit menu, choose Fill Column. 

Entering Student Notes
In addition to comments, teachers can include messages for individual 
students, called student notes. Student notes can print on reports, but not on 
student report cards printed by the school.

If your school uses K12Planet, teachers can choose to export student notes to 
K12Planet. K12Planet does not display student notes by default, however, 
you can change the publishing properties if you wish to display them to 
students and their contacts.

TO ENTER A NOTE FOR A STUDENT:

� From the Class menu, choose Student Notes. 
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Saving Changes to Class Files
As teachers update class files, they need to regularly 
save their changes. 

Working with Seating Charts
The Seating Charts window displays students assigned to a desk. It is a great 
tool for substitute teachers.

Teachers can use it to set the desk order and re-seat students, display student 
pictures, randomly select students from a class, and create seating charts.

TO DISPLAY STUDENT PICTURES:

1 Display the Seating Charts window.

2 From the Class menu, choose Seating Preferences.

TO ASSOCIATE PICTURE FILES WITH STUDENT NAMES:

� Right-click a student desk, and choose Pictures. 
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Reporting Student Grades
During the term, there are a number of reports 
teachers might need to print. 

Customizing Report Headings and Styles

To customize a report, teachers can change the report heading and use the 
appropriate style file. A report differs depending on the style file opened on 
the computer printing the report.

TO CUSTOMIZE A REPORT HEADING:

� From the Class menu, choose Report Headings.

If your school or department has a site license, teachers can also print 
their name on reports. 

Emailing Reports

TO SET UP STUDENT EMAIL ADDRESSES:

1 From the Class menu, select Student Email Addresses, select a name from 
the Student dropdown menu, and type an email address. 

2 Click OK.
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3 From the Report menu, choose the Individual or Multi-Class Report. 

4 Specify your options.

5 Click Email.

Printing Reports

1 From the Report menu, choose a report.

2 Specify your options.

3 Click Print.

Exporting eClass Grades Data to K12Planet
If your school uses K12Planet, teachers need to 
regularly export grades from each class file. 

TO EXPORT eCLASS GRADES TO K12PLANET:

1 From the File menu, choose Export.

2 Select the �K12Planet Grades Export� filter, and 
then click OK.

3 Teachers must select the same individual folder where their setup.gbk and 
*.rst roster files are stored.

Ensure that teachers are saving the export file in the correct folder, and 
NOT a subfolder or the My Documents folder.

4 Click OK.
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APPENDIX C
Teachers complete the procedures in this section. To better understand 
teachers� tasks and be available as a resource, review this appendix, as well as 
appendices A and B.

Teachers� Tasks at the End of the Term
At the end of each grading period or term, or when it is time to send out 
report cards, teachers should:

1 Export term marks.

2 Print reports.

3 Prepare for the next term.

Exporting Term Marks to Mac School or Win School
At the end of term or when it is time to send out 
report cards, teachers export the term marks. 

When teachers enter comments for the next term, 
they wipe out comments for the previous term in 
eClass Grades.

TO EXPORT TERM MARKS:

� From the File menu, choose Export Term Marks. 
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Printing End of Term Reports
At the end of each grading period or term, or when it 
is time to send out report cards, teachers might want 
to print reports. 

Considering the Success of the Previous Term
Teachers should reflect on what they did before the 
start of the previous term, and consider how it relates 
to the next term.

Preparing for the Next Term
At the end of each grading period or term, teachers update class files and set 
up a new grading period.

Updating Class Files
When classes change, teachers need to import an updated set of class roster 
files that you create.

TO CREATE A CLASS FILE:

1 From the File menu, choose New Class.

2 To copy information from a generic class file, from the Class menu, 
choose Copy From. 
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3 To import a roster, from the File menu, choose Import Roster.

4 Save the class.

5 Repeat for each updated class.

Setting Up a New Grading Period
After updating their class files, teachers configure eClass Grades in 
preparation for the next grading period of the school year.

1 In the Assignments window, for each class, verify how many assignments 
were in the first grading period.

2 From the Class menu, choose Grading Periods.

At School Year End
At the end of the school year, teachers print end-of-year reports, and export 
final marks.

Creating Reports and Graphs
At the end of the year, teachers can generate a 
variety of reports and graphs, and customize 
them using the Class and Style menus. 

Teachers can either email or print reports.

Exporting Final Grades
At the end of the year, teachers should export the 
final grades for their students. 
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